松散沉积层三维岩土模型构建
- 三维岩土模型
- 使用指南

简介
本工程模板提供了一套针对松散沉积地层的完整的三维岩土模型构建管道。用户无需从零搭建模型,也无需掌握复杂的三维建模操作,只需准备一套符合规范的钻孔岩性数据和卫星地图,通过"改变数据源"将自有素材替换到模板管道的对应图层中,即可零成本生成自定义的三维岩土模型。本文档将介绍模板的输入图层、输出图层与图层管道;并以另一套钻孔岩性数据和卫星地图进行数据替换,演示使用自有数据生成松散沉积地层三维岩土模型的完整流程。
| 1 打开工程模板文件 2 输入图层 3 输出图层 4 图层管道介绍 5 工程模板文件使用方法 |
|---|
打开工程模板文件
打开EnviFusion软件,如未安装,请先进行EnviFusion软件的安装,链接位于本文顶部,该版本安装后即可直接打开和浏览模板文件。如需对工程模板进行修改保存,请联系北水国际获取EnviFusion专业版。社区版打开界面如下:

专业版打开界面如下,与社区版相比主要增加了计算菜单:

下载松散沉积层三维岩土模型模板文件(EnviFusion-3dSedimentModel-Template-20260917.rar),并将文件解压保存在本地。
点击开始,打开工程按钮
,选择并打开模板文件夹中的EnviFusion-3dSedimentModel-Template-20260917.efp文件。在导入工程文件对话框中,数据文件选项栏选择相对路径,并将模板文件所在文件夹设为数据文件夹;或选择逐一指定数据文件,为每个文件指定来源路径,点击确定打开工程模板文件。

模板内容如下图所示。如视图窗口未出现模型,可点击快捷工具栏中的俯视
按钮,转动视图中模型进行查看。在视图窗口通过按住鼠标左键旋转视图,按住鼠标中键拖动视图的方式查看视图窗口内容。

在图层面板中,勾选图层前方的方框设置图层的可见与不可见,方框中有可见标识的图层则在视图窗口进行展示。

输入图层
第一个输入图层为lithologyData.csv图层,为导入的钻孔岩性数据,该数据为csv格式,具体数据内容如下图所示。重要数据列包括X、Y坐标、TOC(井口标高)、from_(岩性起始深度)、to_(岩性终止深度)、soil_type(岩性类型)、typeID(岩性编号)。

本图层数据通过开始->导入数据
按钮导入。在视图窗口点击视图2,可在表格窗口查看散点数据具体如下图所示。

第二个输入图层为Rectangle#1卫图_Level_19.jpg图层,为研究区对应的卫星地图(jpg格式),通过开始->导入数据
按钮导入,具体如下图所示。

第三个输入图层为文本标注1图层,为项目文件添加标题文字,通过创建数据->标注->文本标注工具生成。
输出图层
第一个输出图层为输出-钻孔点-表格→散点1图层。展示了钻孔岩性底部散点分布。

第二个输出图层为输出-2粉黏土-曲面→曲面(去锯齿平滑)1图层。展示了岩性编号为2的粉黏土岩体(深蓝色岩体)。

第三个输出图层为输出-8泥岩-曲面→曲面(去锯齿平滑)2图层。展示了岩性编号为8的泥岩岩体(红色岩体)。

第四个输出图层为输出-7黏土-曲面→曲面(去锯齿平滑)3图层。展示了岩性编号为7的粘土岩体(橘黄色岩体)。

第五个输出图层为输出-6粉砂岩-曲面→曲面(去锯齿平滑)4图层。展示了岩性编号为6的粉砂岩岩体(黄色岩体)。

第六个输出图层为输出-卫图展示-升维拉伸1图层。展示了裁去研究区范围、并使用伪高程垂向拉伸后的三维卫图,为场地提供卫星地图背景。

第七个输出图层为输出-地层背景-网格→蒙板1图层。展示了裁去研究区范围的地层实体,作为岩土模型展示背景。

图层管道介绍
在管道面板中可以查看本模板的图层管道,如下图所示:

lithologyData.csv图层,为导入的钻孔数据。通过开始->导入数据
按钮导入,
岩性长度-计算器1图层,使用计算->通用工具->属性->计算器工具,根据岩性段的起始深度和终止深度计算岩性长度length。

岩性顶部高程-计算器2图层,使用通用工具->属性->计算器工具,根据岩性段的起始深度和井口标高计算岩性顶部高程from_elev。
岩性底部高程-计算器3图层,使用通用工具->属性->计算器工具,根据岩性段的终止深度和井口标高计算岩性底部高程to_elev。
输出-钻孔点-表格→散点1图层,使用通用工具->散点->表格->散点工具,将表格数据根据x、y坐标和岩性底部高程生成三维散点,并根据岩性编号进行颜色图例展示。

空间变换1图层,为了避免岩性数据插值时受到上下方向的数据影响,本图层将进行垂向放大。点击通用工具->空间拓扑->空间变换工具生成本图层, Z方向缩放调整为100。

散点→线段(高级拉伸)1图层,使用散点->散点->线段(高级拉伸)工具,对空间变换1图层进行拉伸形成线段,图层线段长度缩放系数为100,精度为6,线段上增加的点增加了岩性插值效果。渲染子面板坐标变换Z方向的渲染缩放设置为0.05,可在输出-钻孔点-表格→散点1图层范围看到新生成的点(小一些的圆球)。


注意:*空间变换图层中数据子面板中的Z方向缩放是对数据进行缩放,各图层渲染子面板中坐标变换*属性下的Z方向缩放是对视图效果进行缩放,并不对数据进行缩放。
散点→均匀网格(分区)1图层,根据岩性分类构建岩体。使用通用工具->散点->散点->均匀网格(分区)工具,在散点范围内构建均匀网格,并根据散点岩性类型进行分区,分类构建岩体。该图层渲染子面板坐标变换Z方向的渲染缩放设置为0.05。

空间变换2图层,为方便查看岩体,将散点→均匀网格(分区)1图层岩体垂向缩小20倍(即放大5倍)。点击通用工具->空间拓扑->空间变换工具完成本操作, Z方向缩放调整为0.05。本图层渲染子面板坐标变换Z方向的渲染缩放设置恢复为1。
结构网格→定类边界1图层,使用通用工具->网格->结构网格->定类边界工具,基于指定的分类(岩性编号typeid=2),生成岩体界面。
输出-2粉黏土-曲面→曲面(去锯齿平滑)1图层。对岩体界面进行去锯齿平滑处理,展示了岩性编号为2的粉黏土岩体(深蓝色岩体)。

结构网格→定类边界2、3、4图层,参看步骤11,使用通用工具->网格->结构网格->定类边界工具,基于指定的分类(岩性编号typeid=8、7、6),生成岩体界面。
输出-8泥岩-曲面→曲面(去锯齿平滑)2、输出-7黏土-曲面→曲面(去锯齿平滑)3、输出-6粉砂岩-曲面→曲面(去锯齿平滑)4图层,参看步骤12,对岩体界面进行去锯齿平滑处理,展示了岩性编号为8的泥岩岩体(红色岩体)、编号为7的粘土岩体(橘黄色岩体)和编号为6的粉砂岩岩体(黄色岩体)。

Rectangle#1卫图_Level_19.jpg图层,为研究区对应的卫星地图(jpg格式),通过开始->导入数据
按钮导入。红框内是研究区域。

界面贴图1图层,使用通用工具->标注->界面贴图工具,将输出-钻孔点-表格→散点1图层设为输入图层,将Rectangle#1卫图_Level_19.jpg图层设为栅格图像,调整对齐、图像大小和偏移值,在输出-钻孔点-表格→散点1图层下界面贴上上一步中导入的卫星图。使岩体所在研究区在卫星地图对应的位置。
注:为达到展示效果,本图层渲染子面板坐标变换Z方向的渲染缩放设置为5.


卫星图像→高程1图层,基于卫星图像色彩,使用地学评估->数据资源解析->卫星图像->高程工具,生成伪高程。

等维裁切1图层,为方便展示岩土模型,使用通用工具->空间拓扑->等维裁切工具,将卫星图像→高程1图层裁去岩土模型所在区域。

输出-卫图展示-升维拉伸1图层。使用通用工具->空间拓扑->升维拉伸工具,基于生成的伪高程对卫星地图进行拉伸,为场地提供卫星地图背景。


界面均匀网格1图层,使用通用工具->标注->界面均匀网格工具,在图层基础上生成均匀网格,用于最终地层展示。Z方向外扩系数为地层厚度。

等维裁切2图层,为方便展示岩土模型,使用通用工具->空间拓扑->等维裁切工具,将界面均匀网格1图层裁去岩土模型所在区域。

输出-地层背景-网格→蒙板1图层,使用通用工具->曲面->网格->蒙板工具,为网格添加添加蒙板材质ef沥青,作为地层背景辅助展示岩土模型。

文本标注1图层,为项目文件添加标题文字,通过创建数据->标注->文本标注工具生成。

工程模板文件使用方法
如用户使用EnviFusion社区版打开本工程模板,可在视图面板查看松散沉积地层岩土模型及各图层展示效果,在图层面板和管道面板中查看本模板的图层管道,在属性面板和颜色面板中查看和修改各图层属性设置。
虽然使用EnviFusion社区版无法对工程模板进行新增图层和保存操作,但可以通过导入自有数据,改变数据源方式,利用模板的管道,生成自定义三维岩土模型。具体方法如下:
根据本工程模板输入图层要求,准备研究区域钻孔岩性数据文件(csv格式)和研究区域卫星地图文件(jpg或png格式)。
钻孔岩性数据可参看工程模板中的lithologyData.csv文件进行数据整理。该文件列标题如下图所示,其中重要数据列包括X、Y坐标、TOC(井口标高)、from_(岩性起始深度)、to_(岩性终止深度)、soil_type(岩性类型)、typeID(岩性类型编号)数据,将参与岩土模型构建过程,必须填写。

本文档中准备进行替换的数据为litho.csv,列标题如下图所示:

根据工程模板输入文件格式整理为litho1.csv文件,列标题如下图所示:非重要列空白即可。注:如自有数据已有岩性长度、岩性起始和终止点的高程数据,可单独列出,将其命名为length、from_elev和to_elev。

本文档中自有卫星地图数据为map.png文件。
导入钻孔岩性文件。点击开始->导入数据
按钮,导入本地litho1.csv文件,点击确定后生成litho1.csv图层。点击视图2表格窗口,可查看导入文件具体数据情况。

回到视图1 窗口,在图层面板空白处右击选择隐藏所有图层选项,关闭所有图层显示。
替换原有岩性数据。右击岩性长度-计算器1图层,在选择图层对话框中,选择新导入的litho1.csv图层。替换原有岩性数据。
注:如导入的数据包含了岩性长度、顶底高程数据,则直接选中输出-钻孔点-表格→散点1图层改变数据源。。
展示岩性底部散点。选中输出-钻孔点-表格→散点1图层,在该图层颜色面板图例标注列表中(如颜色面板未在界面中,点击布局菜单,勾选颜色面板即可),点击删除当前记录
按钮,删除之前所有图例;再点击下方从可见数据对象添加活动值
按钮,生成新的图例标注;点击上方显示/隐藏颜色图例
按钮,展示图例信息。可在标注列修改图例名称,如修改成中文;可双击左侧颜色图标修改岩体颜色;点击编辑颜色图例属性
按钮,编辑图例文字颜色、字号等信息。
在本图层渲染子面板二维圆点属性下,根据显示效果修改表示岩性底部散点的圆点半径。



更新岩土模型位置。选中散点->均匀网格(分区)1图层,在该图层属性面板数据子面板中点击重置边界按钮,更新岩土模型范围。


生成岩性编号为1的Miscellaneous fill(填土)岩体。选中结构网格->定类边界1图层,在该图层属性面板数据子面板中将边界值设为1,点击应用绘制岩性编号为1的岩体边界。

在视图窗口仅显示输出-钻孔点-表格→散点1图层和输出-2粉黏土-曲面→曲面(去锯齿平滑)1图层。选中输出-2粉黏土-曲面→曲面(去锯齿平滑)1图层,在该图层渲染子面板调色板属性下,点击纯色下方的编辑纯色按钮,调整岩体颜色,使其与钻孔岩性点中填土颜色一致(紫色),根据岩体效果调整岩体透明度。


生成岩性编号为2-4的岩体。重复步骤8,分别生成岩性编号为2(Sandy silt砂质粉土)、3(Clayey silt粘质粉土)和4(Silty sand粉砂)的岩体,并将其颜色调整为荧光绿、橘黄色和红色。具体颜色RGB值,可参考输出-钻孔点-表格→散点1图层颜色面板图例标注中的颜色RGB值。
可根据岩性名称修改相关图层名称,方便图层查找。

导入研究区卫星地图。点击开始->导入数据
按钮,导入map.png文件,点击确定后生成map.png图层。关闭其他图层显示,在图层渲染子面板其他颜色属性下,关闭使用色板选项,卫星地图如下图所示,研究区域在红框位置。

替换卫星地图文件。选中界面贴图1图层,右击选择改变数据源选项,在选择图层对话框中,将栅格图像选为map.png图层,点击应用替换卫星地图。
仅使输出-钻孔点-表格→散点1图层、曲面→曲面(去锯齿平滑)2图层和界面贴图1图层可见,选中界面贴图1图层,将其着色属性设为PNGImage。点击俯视
按钮,点击2D/3D切换
按钮,将视图变为2D模式,根据岩体所在位置,调整界面贴图对其和偏移参数。



调整卫图参数。原卫图色彩属性为JPEGImage,新卫图色彩属性为PNGImage,需要在卫星图像->高程1图层、等维裁切1图层和输出-卫星展示-升维拉伸1图层的数据子面板和渲染子面板中,更新相关参数。如导入卫星地图为jpg格式,则不需要进行本步操作。

重新裁切研究区域卫星地图。选中等维裁切1图层,在该图层数据子面板中点击重置边界,在渲染子面板中将渲染方式设为外框,通过手柄调整裁切区域。在长方体参数中,自动生成的Z方向原点在曲面上,为保证可以裁切到曲面,调整Z方向原点位置和长度。将渲染方式重新调整为曲面,点击应用完成裁切。
注意:裁切国中中按住鼠标左键转动图层时,裁切的长方体也会发生转动,可重置边界后重新裁切,裁切后关闭显示手柄选项,防止长方体误转。



调整卫星地图展示效果。点击2D/3D切换
按钮,将视图变为3D模式,选中输出-卫图展示-升维拉伸1图层,根据展示效果,调整数据子面板中的升维拉伸缩放因子,调整渲染面板中的Z方向平移,使卫星地图展示在岩体顶部。


调整地质层网格。选中界面均匀网格1图层,修改数据子面板中的Z方向外扩系数,进而修改界面均匀网格厚度。

根据研究范围裁切界面均匀网格。选中等维裁切2图层,在数据子面板中点击重置边界,参考步骤13,裁去岩土模型所在区域。可复制等维裁切1图层中X和Y原点位置和长度参数;将Z方向原点设为界面均匀网格最高点,Z方向长度根据岩土模型厚度进行设置。
注:为方便裁切,可点击俯视
按钮,点击2D/3D切换
按钮,将视图变为2D模式,查看裁切长方体XY方向位置。再回到3D模式,查看裁切效果。

查看松散沉积层岩土模型最终展示效果。仅使输出图层可见,岩土模型如下图所示。

EnviFusion社区版用户可调整视图角度后,点击截图按钮,选择适宜的分辨率保存图像(默认分辨率为当前视图分辨率)。


EnviFusion专业版用户点击开始->保存工程
,将本项目efp工程文件保存在本地。如需再次打开该工程,可在EnviFusion专业版中点击开始->打开工程
,选择保存在本地的efp文件,选择本工程中用到的三个文件的路径,点击确定打开文件。
注:如3个导入文件未发生位置变化,可直接使用绝对路径;如文件位置发生变化,文件都放在一个文件夹中,可使用相对路径定义文件夹位置;如文件位置发生变化且文件位置不统一,则使用逐一指定数据文件。
